Opened 6 years ago

Closed 6 years ago

#10442 closed (wontfix)

Better support for readonly Form fields

Reported by: lsaffre Owned by: lsaffre
Component: Forms Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I saw ticket #3990 , but IMHO, if a ModelForm has an explicit {{{fields}} list,
and if some of these fields are not editable, then they should be rendered as readonly widgets.
That's the least surprising behaviour. Currently they are just ignored.
I am trying to write a patch, but I'm new to Django.

Change History (1)

comment:1 Changed 6 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to wontfix
  • Status changed from new to closed

This looks like a direct dupe of #3990 that you've already found. Since the first step in fixing that requires writing a field-like class that provides static rendering (not a readonly form-field), we should keep this all together in one ticket. So closing as a dupe, since it's very difficult to track something split over multiple tickets doing the same thing.

Note: See TracTickets for help on using tickets.
Back to Top