Code

Opened 5 years ago

Closed 5 years ago

#10419 closed (duplicate)

USStateField breaks admin inlines

Reported by: anonymous Owned by: nobody
Component: contrib.localflavor Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If you make a class with a USStateField and make a ModelForm from it, the resulting select html element will not have a blank option as implied by the docs.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by legutierr

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

This is especially a problem, because without a blank option, admin inlines break. In other words, unless this is fixed, USStateField cannot be used with any Model that might be edited as an inline. If this is used with an inline, then the inline will always produce errors, because the final blank form in the formset will always be seen as being partially filled out rather than completely empty.

comment:2 Changed 5 years ago by legutierr

  • Summary changed from US State Field does not have blank option when rendered as a model form to USStateField breaks admin inlines
  • Version changed from 1.0 to SVN

Changing the title to highlight the most pressing problem. Old title was "US State Field does not have blank option when rendered as a model form".

comment:3 Changed 5 years ago by jacob

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4092

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.