Code

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10255 closed (duplicate)

FileField overwrite existing value with empty one

Reported by: pierpaolodf Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords: FileField
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Since revision 9766 editing in admin will cause overwriting existing value in FileField with blank value.

1) create a new record setting FileField to some file and save it

2) edit the previous record in some field other than the FileField (or just save with no change)

3) check the record to find out that FileField is now empty

Attachments (0)

Change History (6)

comment:1 follow-up: Changed 5 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

This has been already reported in #10121, although it was about ImageField I'm closing this as a duplicate because ImageField is a sublcass of FileField

comment:2 in reply to: ↑ 1 ; follow-up: Changed 5 years ago by Valera_Grishin

Replying to ramiro:

... this as a duplicate because ImageField is a sublcass of FileField

This is why it is better to leave this one open not #10121

comment:3 Changed 5 years ago by Valera_Grishin

  • Cc valera.grishin@… added

comment:4 in reply to: ↑ 2 Changed 5 years ago by kmtracey

Replying to Valera_Grishin:

Replying to ramiro:

... this as a duplicate because ImageField is a sublcass of FileField

This is why it is better to leave this one open not #10121

Convention is to keep the first ticket opened for a problem and close subsequent ones as dupes (though sometimes it is not always realized there is an older ticket already covering a new report, so it is not a convention always 100% followed), noting in the original if necessary anything pertinent. It's been noted the in #10121 that the problem is not specific to ImageField, that's good enough. We only need one ticket to track the problem and it's not particularly critical which one is used.

comment:5 follow-up: Changed 5 years ago by anonymous

  • Cc valera.grishin@… removed

comment:6 in reply to: ↑ 5 Changed 5 years ago by Valera Grishin

Replying to anonymous:
Ok, thanks for explanation. I'm removing my e-mail from cc then.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.