Code

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10228 closed (worksforme)

Inline edit of random model results in "Please correct the errors below." message with no errors listed.

Reported by: lostlogic Owned by: nobody
Component: contrib.admin Version: 1.0
Severity: Keywords: inline, random, admin
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I have a model that is specified ordering = [ '?' ].
It has a foreign key to another model with a definite order.
I have specified that I would like to edit the former inline with the latter in my admin.py.

When I try to perform any edits on the resulting admin page (or even just save it unchanged), I get an error message, with an empty errorlist.

Attachments (2)

admin.py (313 bytes) - added by lostlogic 5 years ago.
Relavent admin.py
models.py (705 bytes) - added by lostlogic 5 years ago.
Relavent models.py

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by lostlogic

Relavent admin.py

Changed 5 years ago by lostlogic

Relavent models.py

comment:1 Changed 5 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed

I just tested this with Django r9820 plus sqlite3 an couldn't reproduce what you report. I tried creating and modifying a Category with zero and more related Link instances (with real edits and just saving without touching anything).

Can you post more details about the Django revision or version you are using?.

Could this be related to some out of synch between your models as you pasted and the tables existing in your DB?. For instance I needed to add the max_length argument to your model's description fields because manage.py syncdb wouldn't even run.

Meanwhile, I'm closing this as worksforme.

comment:2 Changed 5 years ago by carljm

This sounds related to #9758 and/or #9006. Not reopening for now, but it's possible it should be closed as duplicate instead. In addition to Django rev number, what database are you using?

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.