Code

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10221 closed (duplicate)

Admin Documentation Generator throws KeyError on models containing Point fields

Reported by: adamfast Owned by: nobody
Component: GIS Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

django.contrib.admindocs.views in get_readable_field_data_type, line 345 throws a KeyError.

This is because there is no entry in DATA_TYPE_MAPPING for any of the geo fields. I created a patch (that may need better verbose names) and will upload it after saving to get an ID for the name.

This may belong under component django.contrib.admin, but since it's specific to contrib.gis I will assign there for now.

Attachments (1)

ticket_10221.diff (911 bytes) - added by adamfast 5 years ago.
Add mappings for geometric fields to the admin documentation generation

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by adamfast

Add mappings for geometric fields to the admin documentation generation

comment:1 Changed 5 years ago by adamfast

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 5 years ago by adamfast

  • Resolution set to duplicate
  • Status changed from new to closed

Didn't search hard enough. Dupe of http://code.djangoproject.com/ticket/7977

comment:3 Changed 5 years ago by anonymous

  • milestone post-1.0 deleted

Milestone post-1.0 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.