Code

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10217 closed (duplicate)

admin logout problem

Reported by: lashni Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'm using revision 9820, sqlite3, devserver.

I previously filed bug #10061 about a duplicate 'admin' in the logout link within the admin interface, this seems to be a different problem though. Setting up the admin server on a fresh project with only the default models (or my own, makes no difference) when I logout from the frontpage of the admin it hits bug #10061 as expected but when you enter one of the default model areas (groups/users/sites) and hit the logout link the following error occurs:

ValueError at /admin/auth/group/admin/logout/

invalid literal for int() with base 10: 'admin/logout'

eg. broken logout url: http://127.0.0.1:8000/admin/auth/group/admin/logout/

-- full traceback available at http://dpaste.com/hold/118399/

Reproduce:

  • start new project
  • activate admin interface and login
  • click on any of the default models (groups/users/sites) and then click logout.

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #10061.

comment:2 Changed 5 years ago by Alex

I realized my first response is a little nebulous, this is just a symptom of that.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.