Code

Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#10073 closed (fixed)

Collapsed fields in admin break Save as new functionality

Reported by: Uninen Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords: admin, saveasnew, saveas
Cc: kmike84@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If you have collapsed fields ('classes': ('collapse',),)) in admin and save_as = True, when you try to save object as new, you get an error message saying "Please correct the errors below." and no fields marked as being erroneus.

Tested with both Django 1.0 and current trunk.

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by jacob

  • milestone set to 1.1
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 5 years ago by anonymous

Is it a duplicate of #9651?

comment:3 Changed 5 years ago by kmike

  • Cc kmike84@… added

comment:4 Changed 5 years ago by jacob

  • Resolution set to fixed
  • Status changed from new to closed

I'm pretty sure this is indeed a duplicate of #9651 (which is now fixed) and the collapse stuff is a red herring. Please feel free to reopen with a test case if I'm wrong.

comment:5 Changed 3 years ago by jacob

  • milestone 1.1 deleted

Milestone 1.1 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.