Code

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#1003 closed defect (duplicate)

Global name 'rel_opts' is not defined (problem with deleting)

Reported by: Esaj <jason at jasondavies.com> Owned by: adrian
Component: contrib.admin Version: master
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'm not sure what rel_opts is referring to. Should it be related.opts instead?

Traceback (most recent call last):

  File "/home/j/jason/django_src/django/core/handlers/base.py", line 74, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/home/j/jason/django_src/django/contrib/admin/views/decorators.py", line 49, in _checklogin
    return view_func(request, *args, **kwargs)

  File "/home/j/jason/django_src/django/contrib/admin/views/main.py", line 639, in delete_stage
    _get_deleted_objects(deleted_objects, perms_needed, request.user, obj, opts, 1)

  File "/home/j/jason/django_src/django/contrib/admin/views/main.py", line 567, in _get_deleted_objects
    if rel_opts.admin:

NameError: global name 'rel_opts' is not defined

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by rjwittams

Duplicate of fixed 1022

comment:2 Changed 9 years ago by Esaj <jason at jasondavies.com>

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.