Code

Opened 5 years ago

Closed 5 years ago

#10008 closed (duplicate)

JSON Serializer throwing tracebacks

Reported by: erikcw Owned by: nobody
Component: Core (Serialization) Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I just updated to r9729 and now I'm getting this:

Traceback (most recent call last):

File "./manage.py", line 11, in <module>

execute_manager(settings)

File "/usr/lib/python2.5/site-packages/django/core/management/init.py", line 340, in execute_manager

utility.execute()

File "/usr/lib/python2.5/site-packages/django/core/management/init.py", line 295, in execute

self.fetch_command(subcommand).run_from_argv(self.argv)

File "/usr/lib/python2.5/site-packages/django/core/management/base.py", line 195, in run_from_argv

self.execute(*args, options.dict)

File "/usr/lib/python2.5/site-packages/django/core/management/base.py", line 221, in execute

self.validate()

File "/usr/lib/python2.5/site-packages/django/core/management/base.py", line 249, in validate

num_errors = get_validation_errors(s, app)

File "/usr/lib/python2.5/site-packages/django/core/management/validation.py", line 28, in get_validation_errors

for (app_name, error) in get_app_errors().items():

File "/usr/lib/python2.5/site-packages/django/db/models/loading.py", line 128, in get_app_errors

self._populate()

File "/usr/lib/python2.5/site-packages/django/db/models/loading.py", line 57, in _populate

self.load_app(app_name, True)

File "/usr/lib/python2.5/site-packages/django/db/models/loading.py", line 72, in load_app

mod = import(app_name, {}, {}, models?)

File "/home/lm/ytp/rr/models.py", line 9, in <module>

from rr.utils import scrape

File "/home/lm/ytp/rr/utils.py", line 42, in <module>

from django.core.serializers.json import DateTimeAwareJSONEncoder

File "/usr/lib/python2.5/site-packages/django/core/serializers/json.py", line 44, in <module>

class DjangoJSONEncoder(simplejson.JSONEncoder):

AttributeError: 'module' object has no attribute 'JSONEncoder'

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by kratorius

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10006.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.