Opened 7 years ago

Closed 7 years ago

#10001 closed (duplicate)

smart_split should be more versatile

Reported by: zpao Owned by: nobody
Component: Core (Other) Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


smart_split should accept input such that the following is true:

>>> list(smart_split(r"A variable='value' should work."))
[u'A', u"variable='value'" u'should' u'work']
>>> list(smart_split(r"A variable='value with spaces' should also work."))
[u'A', u"variable='value with spaces'", u'should', u'also', u'work.']

With this, multiple word strings can be passed to variables in a template.

Attachments (1)

ticket10001-0.1.patch (2.5 KB) - added by zpao 7 years ago.
Patch v0.1

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by zpao

Patch v0.1

comment:1 Changed 7 years ago by dc

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6271

Note: See TracTickets for help on using tickets.
Back to Top