Changes between Version 11 and Version 12 of OsxFcgi


Ignore:
Timestamp:
03/12/2006 09:21:11 AM (9 years ago)
Author:
radek
Comment:

ahh, not working for python 2.3

Legend:

Unmodified
Added
Removed
Modified
  • OsxFcgi

    v11 v12  
    1 == Getting Django to work with Apache 1.3 and FCGI on Mac OS X ==
     1== Getting Django to work with Apache 1.3 and FCGI on Mac OS X using Python 2.4 ==
    22
    33If you want to use django with mod_python on OS X, you need to install Apache2 first. This involves quite a bit of extra effort and can be difficult to get right. But since Apache 1.3 comes already installed on all OS X systems, for most Mac users, this won't be the best option. The alternative to mod_python and Apache2 is to use FCGI with Apache 1.3, but with the information provided here
     
    1919
    2020django-fcgi.py currently is setup to work with python 2.3 (the default installed on Mac OS X 10.3 and 10.4). When using it with python 2.3 it requires a package called python-eunuchs to provide 'socketpair'. I couldn't get this to compile. However, 'socketpair' is supplied with python 2.4. To use django-fcgi.py with python 2.4 you need to change the shebang at the top of the file to point at python 2.4. YMMV
     21
     22? Can anyone get this python-eunuchs working on Python 2.3 ? / radek
    2123
    2224
Back to Top