Changes between Version 5 and Version 6 of DjangoAndJython


Ignore:
Timestamp:
09/20/2013 02:54:17 PM (23 months ago)
Author:
timo
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • DjangoAndJython

    v5 v6  
    1 You can run Django on the 2.5 branch of Jython.
     1You can run Django on the 2.5 or later branch of Jython.
    22
    3 == Get dependencies ==
    4 Jython depends on the following systems:
     3== Compatibility issues ==
    54
    6  * Java, version 5 or higher. Java 6 is highly recommended for performance.
    7  * Ant, a build system for Java: http://ant.apache.org/
     5Django does support Jython, but it can be a little finicky depending on what apps/versions you want to use.
     6
     7=== Known good configurations ===
     8* Django 1.3.1 with Jython2.7b1 with django-jython1.3 (note that Django 1.3.X is no longer supported and does not receive security fixes!)
     9
     10=== Known to be incompatible ===
     11* Django 1.4+ with any version of django-jython -- [https://code.djangoproject.com/ticket/19417 know issue with DateTimeField].
     12
     13=== Supported plug-ins ===
     14
     15==== Plug-ins known NOT to work ====
     16* Django REST framework
    817
    918== Check out and Install Django/Jython ==
    1019
    11 See http://wiki.python.org/jython/DjangoOnJython
     20* [https://docs.djangoproject.com/en/dev/howto/jython/ Offical Django documentation]
     21* See also: http://wiki.python.org/jython/DjangoOnJython
Back to Top