Opened 2 years ago

Closed 2 years ago

#19118 closed Cleanup/optimization (duplicate)

query_string should by decoded to utf-8

Reported by: alex_po Owned by: nobody
Component: Python 3 Version: master
Severity: Normal Keywords: query_string
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

A query string at line 390 in django/http/__init__.py should be decoded to utf-8.

Attachments (1)

path.diff (619 bytes) - added by alex_po 2 years ago.

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by alex_po

comment:1 Changed 2 years ago by alex_po

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Sorry, there is should be verification is query dict is string or bytes.

Version 0, edited 2 years ago by alex_po (next)

comment:2 Changed 2 years ago by aaugustin

At first sight this is a duplicate of #19075, but please reopen it if it's a different problem.

comment:3 Changed 2 years ago by aaugustin

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
Back to Top